Vector Editing

Sketch is a vector-based design tool, which means you can create, and edit existing shapes by modifying their points and paths. Shape Editing covered an introduction to vectors, but this chapter takes an in-depth look to Sketch’s vector editing capabilities.

To enter Sketch’s vector editing mode, select either a shape layer, and double-click it (or press the Enter key), or choose Insert › Vector from the pop-up menu in the toolbar to start drawing a new shape layer.

For an in-depth article about how vector editing works in Sketch, as well as some best practices, check Peter Nowell’s excellent Mastering the Bézier Curve in Sketch. It is both technical, and accessible.

Join

With two or more open paths selected, choosing Layer › Path › Join will combine them into a single continuous path. The bottom-most path in the selection will stay in position, whilst path layers above it may move slightly to fit together.

Convert to Outlines

Whilst you can convert a text layer to outlines to edit its points, you can also convert a layer’s border to outlines too, exactly the same way. Choose Layer › Convert to Outlines from the menu (or press Shift-Command-O) and the border on your selected layer will become a path with its very own fill.

Offset Path

You can expand or contract the outline of a selected shape by choosing Layer › Path › Offset… from the menu. Once selected, you can adjust the slider to view how your shape would look like if it was offset. Similar to how the shape would appear if its inner or outer border appeared as an actual path.

This is a destructive action, so you also have the ability to duplicate the existing layer to preserve it.

Offset path

Reverse Order

A path’s direction is determined by the order in which its points are placed, meaning that there is a start point, and an end point if a path is open. Choosing Layer › Path › Reverse Order can swap the start and end points of a path which allows you to place your next point from the opposite end, or to switch the place of an arrow that can appear as part of a border.

Last modified on Oct 11, 2018

Was this article useful?

Yes
No

We’re really sorry about that.
Please let us know what you were looking for:

If you need more help or you’d like to report a bug with this content, please contact support.

Thanks for your feedback.
An error occurred, please try again later.

In this section…

Start working faster today

Available exclusively on the Mac for just $99.