Creating Symbols

To create a Symbol, select a group, Artboard, or a selection of layers and click the Create Symbol item in the toolbar, or choose Layer › Create Symbol in the menu.

A dialog will appear allowing you to name your Symbol, and give you the option to send the Symbol’s “master” to a different page. After you’ve created the Symbol you’ll see the contents have been flattened to a single layer, called an “instance” in the Layer List.

If you leave the checkbox unselected, then the Symbol’s master will be placed on the page you’re on, and an instance will take its place.

Create new Symbol
This dialog will appear when you create a Symbol, allowing you to send the master to a different page.

Now you can choose Insert › Symbol from the pop-up menu, and insert a new instance of your Symbol into the Canvas. Likewise, you can copy and paste or duplicate an existing instance of a Symbol and Sketch will link them together as well.

To create a nested Symbol, just place a Symbol’s instance inside another Symbol’s master.

If you want to convert a Symbol master back into a regular Artboard, select the Symbol Artboard in the Layer List, and choose Layer › Create Symbol from the menu. This will change this Symbol’s instances into groups, and any edits made to it will no longer update between copies.

Detaching Symbol instances can be done the same way, by choosing Layer › Detach from Symbol from the menu, or shortcut menu when Control-clicked.