Sketch 3.3

What's new in version 3.3

New Features

  • Improves speed and reliability of Sketch Mirror
  • You can now connect to Sketch Mirror by entering an IP address (please update your version of Sketch Mirror to 1.3 to view the device’s IP)
  • Edit › Scale now gives you a live preview
  • Documents now hold their own gradient and color presets as well as the global presets
  • Layer dimensions can now be set as a relative value (i.e: you can set a layer’s width to 50% and it will resize to half the size of the artboard or group it is in)
  • You can now set independent opacity, blending options, and shadows for Symbols
  • Frequently used colors have moved to the Color Preview box and they will now also show you how often they’ve been used and where

Enhancements

  • Outlining Strokes has been improved significantly
  • ‘Mask with Shape’ enhanced to detect when you probably want to use an Alpha mask
  • You can now define how layers will resize when using the inspector: for width, you can add a M (middle) / C (center) or R (right) suffix to indicate which edge of the layer should remain fixed. Similarly for the height you can use M (middle) / C (center) and B (for bottom)
  • Text alignment has been made recursive; you can select a group and align all text layers inside easily
  • Text layers now have locked proportions after converting to outlines
  • ‘Make Grid’ now only optionally fills missing cells with duplicated layers
  • Copy-Pasting a style now also transfers a border’s arrow types across
  • When two objects snap to each other, the distance between them is now always shown
  • Resize handles no longer disappear when a shape is being rotated
  • Improved curve smoothing in the Pencil Tool
  • Shared Styles now also include the arrow on line ends
  • When changing a Symbol instance to a new Symbol type, Sketch is now smarter about preserving excluded text values between the two
  • PDF and EPS can once again be exported to multiple resolutions
  • When closing the popover in text edit mode, you can now immediately continue typing in the text layer
  • The Type menu and Font window now update to reflect the current selection better
  • Updates Artboard presets to include the latest iOS and Apple Watch screen sizes
  • The option key can now be used to move and resize layers in 0.1px increments, but still allows distance measurements
  • You can now customize the arrow nudge distance (used for moving and keyboard-resizing) by using two hidden default keys, nudgeDistanceSmall and nudgeDistanceBig
  • Introduces a new plugin file format
  • Improves the naming of new and duplicated layers, styles and shared objects
  • To make it easier to spot that you’re editing a Symbol, they now have a purple highlight in the canvas and layer list
  • Fill and Border options can now be accessed through the menu (Layer › Style)
  • Reorganises and simplifies the View menu to make it easier to find common items
  • You will now be notified when a device running Sketch Mirror appears for connection
  • Opening a bitmap image in Sketch no longer adds an automatic slice
  • The width and height measurements when drawing and resizing shapes are now shown besides the mouse cursor, to make them visible at all times

Bug Fixes

  • Inserting an image via drag and drop now places it at the correct location in the layer hierarchy
  • Fixes a bug where Sketch could crash when creating a Symbol from Shape Paths
  • Flattening bitmaps no longer flattens them to 2x resolution by default
  • Fixes a bug where shapes with subpaths wouldn’t recalculate their bounds when their boolean ops changed
  • Fixes a bug where the tab order in the color inspector was unexpected
  • Fixes a bug where flattening bitmaps on a retina screen might have them jump by a pixel
  • Layer Alignment has been improved to snap independently of axis
  • Fixes a bug where the Edit › Scale sheet would not recognise the most recent input
  • Fixes a bug where the line height field wouldn’t accept decimal numbers
  • Fixes a bug where a Star’s radius could go beyond 100%
  • The export preview is now properly centered in the inspector
  • Magic Wand now properly supports varying DPI images
  • Smart guides no longer pick up measures for locked layers
  • A Star’s radius now just increments by 1% instead of 10%
  • Fixes a bug where disabled borders on text layers would show the trash can in the wrong location
  • Fixes a bug where setting corner radius on individual points wouldn’t be restricted to integer values
  • Fixes a bug where drawing a closed path using the Pencil tool could have the path disappear
  • Fixes a bug where a layout grid’s values could be set to invalid values
  • Edit › Select All when layer interaction is disabled now selects all slices, also in subgroups
  • Fixes an Undo issue when setting Text Lists
  • Fixes confusing undo labels when editing text
  • Fixes a bug where images with blending and bitmap effects would not be rendered properly
  • Scissors tool now works correctly when multiple subpaths are involved
  • Fixes a bug where an outer path might leak a fill
  • Fixes a bug where duplicated Symbols would take the name from the group, instead of the previous Symbol
  • Smart Name suffixes are now also used for Duplicated Symbols and Styles
  • Fixes keyboard shortcuts on Dvorak, Colemak and non-Latin keyboards
  • Fixes a bug where the color preview box would not show a color with opacity when the real color had none
  • Fixes a bug where alt-dragging and then duplicating might not remember the offset
  • Improves snapping accuracy, especially for text layers
  • Fixes a bug where a color preview wouldn’t show the right opacity
  • Fixes a bug where dragging a rectangular area could leave artefacts
  • Fixes a bug where editing rotated images could leave artefacts