Sketch 3.2

What's new in version 3.2

New Features

  • New Google Material Design template and artboard sizes.
  • Adds support for Sketch-Mirror and @3x scaling.
  • Align and Distribute tools now work for Vector points too.
  • You can now measure the distance from a shape to a grid or guide line using the Alt key as well.
  • Alt + click on the Inspector's align buttons to align the entire selection with their parent artboard.
  • Added a new preference to choose the resolution to which bitmaps are flattened when doing Layer › Flatten Selection to Bitmap.
  • When rotating objects, the pivot point can now be moved.
  • Shift+Return now inserts a line break instead of a paragraph break in text editing mode.

Enhancements

  • Significant speed improvements, especially when working with complex documents, Make Grid for large grids and undo & redo actions.
  • Improves PDF importing.
  • When changing text line height, the first line no longer clips off the top.
  • Renamed the Paste option in contextual menus to "Paste Here", to make the functionality clearer.
  • Improved compatibility with Yosemite.
  • Multiple corner radii for rectangles can now be provided from the inspector field using top/left/bottom/right syntax.
  • When duplicating layers or groups with slices in them, Sketch will now make sure their names are uniqued.
  • You can now perform math operations in the color (RGB/HSB) text fields.
  • Improves 'Copy CSS Attributes' for cleaner and more modernised output.
  • Inserting slices now always places them directly in the correct group, and they take the name of their parent group automatically.
  • Pixel grid can now also be shown and hidden in vector preview.
  • When vector points are hidden, the currently selected point handles are still being shown.
  • Smart guides in vector tool now also work as expected when the vector points are hidden.
  • When changing a subrange of a text with a shared style, the entire string now changes to reflect it.

Interface

  • Double-click on the zoom icon in the toolbar now zooms back to 100%.
  • Alt-clicking on the Move Forward/Backward toolbar buttons moves to front or back instead, and now also updates their labels to indicate this.
  • Auto-expanding of groups in the layer list is now optional. Also, Sketch now persists the expanded/collapsed states of groups in the layer list between restarts.
  • Artboard preset group now remember their collapsed state.
  • Scale fields now disable properly when exporting in vector formats.
  • The Release Notes can now be shown from the Help menu as requested.
  • You can now hide all Grids and Layouts in one click from the View menu.

Bug Fixes

  • Fixes a layer renaming bug in the layer list with multiple selections.
  • Fixes a bug where 'Make Grid' could make objects jump.
  • Fixes a number of refresh issues in vector editing mode.
  • Fixes a bug where changing blurred objects radius could seem to make it jump around weirdly.
  • Fixes a rare bug where documents with embedded pdf images could crash.
  • Fixes a bug where the Insert-Artboard inspector wouldn't work as expected when a layer was already selected.
  • Fixes a bug where one couldn't grab the handles of rotated shapes in groups.
  • Fixes a bug where background blur on rotated objects would misbehave.
  • Fixes a bug where deleting large numbers of layers would become really slow.
  • Fixes a bug where editing points in zoom-blurred layer wouldn't refresh the canvas properly.
  • Fixes a crasher that could occur when closing complex documents.
  • Fixes a bug where a text layer with a stroke and shadow might not display the right fill color.
  • Fixes a bug where font ascenders could get cropped under a text layer.
  • Fixes a bug where big shadows on text layer could get clipped.
  • Fixes a bug where nudging a shape inside a smaller artboard would move it out.
  • Fixes a bug where pasting text wouldn't strip the text style properly.
  • Fixes a bug where the system sharing sheet wouldn't export SVG files.
  • Fixes a bug where text layers wouldn't scale down properly.
  • Fixes an undo bug when pasting and reordering layers.
  • Fixes a bug where you could select layers inside locked groups.
  • Fixes a bug where the toolbar zoom icons wouldn't respond correctly.
  • Fixes an issue in using the screen color picker on multi-screen setups.
  • Fixes a refresh issue in using subpaths with thick strokes.
  • Fixes a refresh issue when moving artboards around with guides.
  • Fixes a Magic Wand bug on Retina screen.
  • Fixes a bug where slice names wouldn't get de-duplicated after copying.
  • Fixes a bug where pasted text background might stay around during edit and couldn't be removed.
  • Fixes a bug where layers dragged to new pages wouldn't get selected.
  • Fixes a bug where axis-constraining using shift when dragging layers wouldn't work.
  • Fixes a bug where selecting layers in the list could make the list jump around unexpectedly.
  • Fixes a bug where the color inspector would highlight the wrong color as being the current fill/border.
  • Fixes a bug where the Export button in the toolbar would add an incorrect slice to the document.
  • Fixes a bug where hiding a naming during renaming it would make its name invisible.
  • Fixes a bug where shadows wouldn't display correctly when being inside rotated or flipped groups.
  • Fixes a bug where text could unexpectedly be set to fixed width.
  • Fixes a bug where rotated shapes in groups would scale incorrectly.
  • Fixes a bug where measurement numbers for flipped layers would be flipped too.
  • Fixes a bug where text excluded from Symbol sync could act in an unpredictable way.