Sketch 3.1

What's new in version 3.1

  • Sketch's file format has changed; documents are now truly single files and can be safely emailed or shared via Dropbox and other services without having to zip them up first
  • Creating Masks has been made easier; the Mask-with-Shape button now accepts any combination of layers
  • Boolean op'ed shapes' bounds now only include the visible area only, not the total bounds of all subpaths
  • Layer snapping has been made smarter, including better text snapping
  • You can now add ruler guides with a single-click on the rulers
  • Significant speed increases and file size reduction when using pattern fills
  • Hover the Rulers for a quick preview of your next guide. Ideal also for quickly checking if layers align etc
  • Fixes a bug where Opacity wouldn’t be rendered consistently between shapes and bitmaps
  • Rendering speed improvements
  • Fixes a bug where text editing could jump slightly when zoomed in some cases
  • Pages Panel has been redesigned and now fits as a permanent sidebar in the UI
  • You can drag/drop layers to the pages panel to quickly move objects between pages
  • Fixes a bug where Sketch could crash when a symbol name started with @
  • Fixes all known bugs in Framer - Sketch integration
  • Improves integration with the system color picker for gradients
  • Cmd+Return can now be used to exit text editing mode
  • You can now reset the rulers by double-clicking the ruler intersection area
  • Improves the zoom tool on dark backgrounds
  • Significant speed improvements when the rulers are visible
  • Improves undo for renaming layers
  • Fixes a bug where renaming Symbols could cause a crash
  • Fixes a bug where dragging out an SVG slice could crash Sketch
  • The Scissors Tool now scales properly with zoom value
  • Fixes a bug where patterns wouldn’t be drawn in the shared styles preview
  • Fixes a bug where Angular gradients could be rendered at low resolution
  • Fixes a bug where adding a guide could place it on subpixels
  • Fixes a bug where slices created for rotated objects could be one pixel off
  • Fixes a bug where point coordinates outside an artboard could be wrong
  • Due to popular request (no it wasn’t a bug), we’re making move Forward/Backward dumb again
  • You can now replace the contents of an image layer with a new image by going to Layer › Image › Replace
  • Restore an image to its original size by going to Layer › Image › Original Size
  • Fixes a bug where some documents could consume extraordinary amounts of CPU
  • Color and Gradient presets now display a checkered background when they’re transparent
  • Fixes a bug where creating a slice for a transparent layer could make the slice too big
  • Large patterns are now properly scaled to fit the small preset previews
  • Fixes a bug where deleting an artboard could leave its outline on the canvas in some cases
  • Fixes an issue where Gradient editing was confusing when started on a subpath
  • Fixes a bug where 'Bring to Front' on multiple layers could get their order mixed up
  • Fixes a bug where extra spaces wouldn’t get trimmed around slice names
  • Fixes a bug where moving layers off an artboard with the arrow keys would never actually remove them from the artboard
  • Fixes a bug where inserting an artboard while you were in a rotated group could look funky
  • Fixes a bug where pasted text could be invisible at first
  • While inserting a layer you can now drag outside the canvas to make the view scroll
  • When changing guides in the preferences, the canvas now updates live to reflect the change
  • Moves Grid color settings to the grid settings sheet to make it more discoverable
  • Inserting points in vector mode on an existing line now also honours rounding preference
  • Fixes a bug in bitmap cropping
  • The templates folder can now be an alias or symlink
  • Fixes a bug where layer naming would go wrong
  • Vector point coordinates in the inspector now round to two decimals
  • When you resize an artboard from the top or the left, the content stays anchored in the canvas now instead of shifting left or up
  • Symbols and Text Styles menu can now be arbitrarily deeply nested by using / in their names
  • Fixes a bug where text layers wouldn’t render multiple fills
  • Shift-clicking on a vector point now deselects it if it was already selected
  • View -> Collapse Groups has been renamed to include Artboards too
  • Fixes a bug where Magic Wand would miss the top 1 pixel
  • Flattening layers into a bitmap now inserts the bitmap at the location of the old layers instead of on top
  • Fixes Shared Styles break when copying and pasting style
  • Fixes a refresh issue when changing text layers from fixed to flexible width
  • Fixes a bug where Pencil vectors would not end up in the correct artboards
  • Ignore character spacing for the last character to not miss with centred text
  • Fixes a bug where making a grid of objects could rename the source object as well