Version history

Sketch is constantly improving. Check the list below to see what we’ve added in the major updates since we launched version 3.0.

What's new in version 3.4.4

Enhancements

  • Updated iOS App Icon Template
  • Improved SketchTool by allowing exporting by ID: Use --use-id-for-name option
  • Improves compatibility with Corporate Installers and their codesigning

Bug Fixes

  • Fixes a bug where opening large documents created in older versions would take far too long
  • Fixes a bug where changing the name of a text layer in the list view would not stick
  • Fixes a bug where SketchTool would fail to dump the tree structure of entire documents in certain cases
  • Fixes a bug where Shared Styles or Symbols could get unlinked when renaming them

What's new in version 3.4.3

Bug Fixes

  • Fixes a bug in scripting which sometimes returned the incorrect document
  • Fixes a crash with documents using Shared Text Styles
  • Fixes an issue where the Layer List would not be refreshed properly when deleting layers
  • Fixes a bug when editing non-transparent images

What's new in version 3.4.2

Enhancements

  • Added iPad Pro and tvOS Artboard Presets
  • Added option to indicate whether the opacity of an image should translate to its fill
  • Improves the behaviour of the Layer List auto-collapsing after deleting layers
  • Updated iOS UI Design Template

Bug Fixes

  • Fixes a bug where images with fills would blend unexpectedly
  • Fixed a bug where some text layers would display the first line at the wrong position
  • Fixed a bug where legacy 9-slice images would not render properly
  • Fixed a crash when editing gradient fills on 10.11
  • Fixed a rendering bug where layer blend modes in combination with shadows and fills could look differently
  • Fixed a possible crash in documents with multiple background blurs
  • Fixed a crash when exporting layers at very small sizes
  • Fixes a significant memory leak in documents using many artboards
  • Fixes a bug where certain PDFs would not import properly
  • Fixes a rare bug where some symbols would fail to sync their changes across
  • Fixes a rare bug where edited images could disappear
  • Fixes a bug where transparent images could be trimmed on import
  • Fixes a couple of bugs in Boolean Operations
  • Fixes a bug that would seem to prevent documents from saving

What's new in version 3.4.1

Enhancements

  • Updated iOS UI Design Template.
  • Added support for menu separators in Plugin options ("-")
  • Improved behaviour when entering values in the border dash fields.
  • Improved behaviour of insertion point color when editing text.
  • Improved capitalization style consistency in Preferences.

Bug Fixes

  • Fixed a crash where shared layer styles may be wrongly applied to text
  • Fixed a crash when setting text colors with non-RGB color spaces
  • Fixed a crash when pressing Escape in an empty font search field
  • Fixed a crash when using the color picker in Grid or Layout Settings
  • Fixed a crash that could occur when closing documents
  • Fixed a rare crash that could occur when rendering was cancelled
  • Fixed an issue that caused some Plugins to stop working
  • Fixed an issue in Boolean operations which reversed operations for orthogonal shapes
  • Fixed an issue when a dash length shorter than 1 was entered
  • Fixed an issue where two levels of zoom may be seen at once when pinching to zoom
  • Fixed an issue when copying multiple shadow's CSS properties when one shadow was disabled
  • Fixed an issue where a selected Artboard could not be moved on the canvas
  • Fixed an issue where pressing Z and then Option, and then clicking multiple times, would only zoom out once
  • Fixed an issue where having invalid characters in the filename would prevent Local Sharing from working correctly

What's new in version 3.4

Enhancements

  • Artboards can now be previewed in a web browser and shared on the local network
  • Significantly faster and much more accurate Boolean Operations
  • Improved and more predictable copy and paste
  • You can now disable Auto Save in the Preferences
  • Added Artboard preset and template file for Material Design icons
  • You can now create a quick mask for a selected bitmap just by clicking the Mask button in the toolbar
  • Measuring distances between layers now also works with ⌘ (Command) to drill down into groups
  • You can hold ⌥ (Option) to switch between Lock and Hide icons in Layer List
  • You can now Option-hover layers in the Layer List to measure distances between it and the selected layer
  • Added the ability to change the selected Artboard’s background color using Control-C
  • Improved Undo/Redo reliability
  • You can now edit the Layout or Grid for multiple Artboards at the same time
  • When pixel fitting is off, we no longer move layers by 1px increments. When it’s on, we always snap to full pixels
  • Removed the ability to nudge a layer by 0.1px when holding ⌥ as it conflicted with other shortcuts
  • Rotating a layer in the Inspector will now rotate clockwise
  • Export previews now use a checkerboard pattern to show transparency for white and light objects
  • Improved the way Symbols treat text layers with multiple font styles
  • When background blur is turned on we now automatically make any fills on the same layer semi-transparent
  • Make Grid now respects the “Rename Duplicated Layers” preference
  • Removed the double Export buttons on the Artboard Inspector and realigned the previews correctly
  • “Replace Image…” option when right-clicking an image
  • Improved Background Blur rendering
  • Zooming performance improvements, especially for fast consecutive zoom actions, or traditional mouse-wheel scrolling
  • Improved the behaviour of using ⇧ (Shift) to lock movement of layers
  • Added the ability to drag embedded SVG images directly from the browser into Sketch
  • Preferences now includes pane to manage installed Plugins
  • Scrollbar in the layer list no longer obscures the hide/lock icons
  • New gradients are now based on the current fill colour
  • International-friendly §-key feature to zoom to 100% when held (~ key on US keyboards)
  • The command line SketchTool is now embedded inside Sketch
  • Changed behavior of zooming when you hold ‘Z’ and drag. The zoom tool will stay active even if you release ‘Z’.
  • If you press ‘Z’ while already dragging, it will not begin zooming. It will only activate the zoom tool if ‘Z’ is pressed before the drag.
  • Plugins can optionally disable CocoaScript preprocessing

Bug Fixes

  • Fixed a crash when attempting to export images that have accidentally been made insanely large
  • Fixed crash when deleting a Shared Style whilst editing its name
  • Fixed a crash when resizing a group via the Inspector
  • Fixed a crash when adding a Page whilst the document was being saved in the background
  • Fixed a crash when pasting an empty string
  • Fixed an occasional crash after editing text
  • Fixed an occasional crash when changing fonts
  • Fixed a crash with the Layout Settings and Grid Settings panels
  • Fixed a crash when dragging a Slice preview
  • Fixed a crash when closing window on 10.11
  • Fixed a crash when organize Text Styles sheet is open in two documents at once
  • Fixed an occasional crash when stepping a value up or down in the Inspector
  • Duplicating a layer no longer loses focus
  • Reverting a document to a previous state no longer causes refresh issues
  • Patterns are no longer sometimes displayed at the wrong scale
  • Renaming a style now gives it a different identity, so copying and pasting between documents will no longer change a style with the old name in the pasted document
  • Rotated subpaths now have correct coordinates
  • Pasting a shape with a pattern uses the correct scale
  • Edit > Scale no longer ignores multiple text sizes on text layers
  • Improves anti-aliasing of bitmap layers when zoomed in
  • Reliability of Quick Look previews improved
  • iPhone 6 Plus-sized Artboard scales correctly to Mirror
  • Copying a Text Style with a non-default line height between layers no longer causes problems
  • Switching from a transparent gradient to a color fill no longer produces a faulty opacity on the fill
  • Sub-layers of a hidden groups no longer display their selection outline
  • The shared Text Style preview updates correctly when the Inspector changes
  • Text focus returns properly to the text handler after making changes in the Inspector
  • ‘Revert to Saved’ redraws a document correctly
  • Background-blurred layers no longer have white edges
  • Holding ⌘ to disable snapping when moving points now hides existing snapping guides
  • The Color Picker correctly highlights identical colors among the presets
  • Selecting an Artboard no longer enables the Rotate toolbar icon
  • Command-hovering overlapping layers no longer produces redrawing glitches
  • Resizing rotated shapes with the keyboard no longer expands them
  • Dragging around a mix of layers and Artboards with guides no longer produces redraw glitches
  • Text layer’s hover shows at correct position
  • The Inspector updates correctly after aligning multiple layers
  • Dragging a layer into an Artboard correctly enables the Align buttons
  • Edit > Scale correctly scales dashed borders
  • Converting Text to Outlines no longer moves the layer to the top of the hierarchy
  • Transform and Edit buttons would not be disabled when they should be
  • Text color no longer reset after switching text from lowercase to uppercase
  • Inserting text with a Shared Style no longer overrides the style from another shared Text Style
  • Distance measurements no longer produce duplicate measurements on grids with small spacing
  • Shapes can no longer be left in an invalid state after Undo
  • Resizing multiple layers at once no longer causes them to jump around
  • No longer possible to turn the Text tool into the Rectangle tool halfway through a drag
  • Blended pattern fills export correctly
  • Deeply nested text can be edited
  • Dragging after right-clicking no longer moves unexpected layers
  • Rotated shape bounds no longer jump when scaling its parent group
  • Text layers no longer wrap their contents unwantedly when re-opening a document
  • Artboard positions are now always appear on whole pixels
  • Toggling sub-pixel anti-aliasing in the Preferences now immediately refreshes the document
  • Cutting and Pasting layers now properly updates the rulers
  • Mouse cursors update correctly when using shortcuts
  • Improves the undo handling of the Edit > Scale sheet
  • Locking or unlocking layers made more consistent when there’s a mix of locked and unlocked layers
  • Removing a mask updates the canvas correctly
  • Improves performance when interacting with Artboards and Slices by being smarter about delaying and cancelling preview regeneration
  • Adjusting text line height during editing no longer moves the layer
  • Group bounds now correctly match their contents
  • Undoing a gradient stop change no longer turns it gray
  • Improved reordering of Artboards in the Layer List
  • Images with an alpha channel now render blended fills correctly
  • Fill preview in Inspector now updates correctly when pattern fill image is changed
  • Color popover highlights correctly when selecting a preset
  • The Mirror popover now refreshes if it is open when the device list changes
  • Layers flattened to bitmap now automatically lock their proportions
  • Zoom to Selection whilst editing a bitmap now uses the bitmap’s selection
  • Cancelling editing of a bitmap no longer causes it to resize unexpectedly
  • When hovering over a group in the layer list, the bounds shown on the canvas are now correct
  • Blank images now export at the correct size
  • The Scale sheet is no longer resizeable
  • Opacity value now updates correctly in the popover when edited outside it
  • Blend modes for fills now render correctly
  • Snap distances now display while holding ⌥ (Option) and hovering over the Layer List
  • Fixes a rare possible when flattening layers down to bitmaps
  • Fixes a rare text rendering related crasher
  • Restores the behaviour where you can press Tab in the Font picker to go back to the search field
  • Fixed a crash when using the Magic Wand tool
  • Fixes a cosmetic issue with the drawing of the Layer List separator on retina screens
  • Fixes an issue with the Magic Wand tool not working properly in certain circumstances
  • Fixes a bug where the Magic Wand tool could leave drawing artifacts on the canvas
  • Rendering of overlapping bitmaps with non-opaque fills now works in all cases. It was sometimes getting clipped
  • Rendering of embedded groups with shadows no longer shows artifacts like clipping or onion-skinning when dragging
  • Improved the behaviour of pasting from the context menu in the Layer List
  • When you hold ‘Z’ and drag, it now zooms in all cases. Previously, there were occasions where it would only translate, not zoom
  • Fixed a hang when duplicating documents
  • Fixed an issue where flipping or rotating a layer didn’t update when Color Adjust was selected

What's new in version 3.3.3

  • Fixes a rare bug where a pasted image could disappear
  • Fixes network related beach-balling on some machines, caused by a change in the behaviour of Apple's security layer
  • Fixes an occasional problem with validating licenses
  • Fixes a bug where zooming using ⌘+ would be very slow on some systems, even on nearly empty docs

What's new in version 3.3.2

  • Adds a new preference to avoid aligning layers on sub-pixels
  • Fixes a bug where inner shadow would render incorrectly on bitmaps
  • Fixes a bug where text layer with small line height might cause refreshing issues
  • Updated toolbar icon for 'Edit' to make it clearer that bitmaps can also be edited
  • Distance measurement no longer takes up cues from layers which are both hidden and locked
  • You can now perform math operations on a text layer’s Size, Character, Line and Paragraph input fields
  • Fixes a bug where trying to zoom into a document past 6400% with the zoom tool would make the canvas jump in unexpected ways
  • Fixes a bug where measuring distance between layers on sub-pixels could give the wrong result
  • Fixes minor UI layout issues in the Inspector
  • Fixes a bug where creating a symbol wouldn’t let you enter a name for it

What's new in version 3.3.1

  • Fixes a bug where the first time a document from an earlier version was opened, editing an image in it could cause the image to be lost when the document was saved.
  • Fixes a bug where custom colors and gradients set up in older versions of Sketch were reset to their default values.
  • Fixes a bug where creating a new symbol wouldn't allow you to rename it.
  • Fixes a bug where artboards wouldn't be scaled to the right sizes in all cases.

What's new in version 3.3

New Features

  • Improves speed and reliability of Sketch Mirror
  • You can now connect to Sketch Mirror by entering an IP address (please update your version of Sketch Mirror to 1.3 to view the device’s IP)
  • Edit › Scale now gives you a live preview
  • Documents now hold their own gradient and color presets as well as the global presets
  • Layer dimensions can now be set as a relative value (i.e: you can set a layer’s width to 50% and it will resize to half the size of the artboard or group it is in)
  • You can now set independent opacity, blending options, and shadows for Symbols
  • Frequently used colors have moved to the Color Preview box and they will now also show you how often they’ve been used and where

Enhancements

  • Outlining Strokes has been improved significantly
  • ‘Mask with Shape’ enhanced to detect when you probably want to use an Alpha mask
  • You can now define how layers will resize when using the inspector: for width, you can add a M (middle) / C (center) or R (right) suffix to indicate which edge of the layer should remain fixed. Similarly for the height you can use M (middle) / C (center) and B (for bottom)
  • Text alignment has been made recursive; you can select a group and align all text layers inside easily
  • Text layers now have locked proportions after converting to outlines
  • ‘Make Grid’ now only optionally fills missing cells with duplicated layers
  • Copy-Pasting a style now also transfers a border’s arrow types across
  • When two objects snap to each other, the distance between them is now always shown
  • Resize handles no longer disappear when a shape is being rotated
  • Improved curve smoothing in the Pencil Tool
  • Shared Styles now also include the arrow on line ends
  • When changing a Symbol instance to a new Symbol type, Sketch is now smarter about preserving excluded text values between the two
  • PDF and EPS can once again be exported to multiple resolutions
  • When closing the popover in text edit mode, you can now immediately continue typing in the text layer
  • The Type menu and Font window now update to reflect the current selection better
  • Updates Artboard presets to include the latest iOS and Apple Watch screen sizes
  • The option key can now be used to move and resize layers in 0.1px increments, but still allows distance measurements
  • You can now customize the arrow nudge distance (used for moving and keyboard-resizing) by using two hidden default keys, nudgeDistanceSmall and nudgeDistanceBig
  • Introduces a new plugin file format
  • Improves the naming of new and duplicated layers, styles and shared objects
  • To make it easier to spot that you’re editing a Symbol, they now have a purple highlight in the canvas and layer list
  • Fill and Border options can now be accessed through the menu (Layer › Style)
  • Reorganises and simplifies the View menu to make it easier to find common items
  • You will now be notified when a device running Sketch Mirror appears for connection
  • Opening a bitmap image in Sketch no longer adds an automatic slice
  • The width and height measurements when drawing and resizing shapes are now shown besides the mouse cursor, to make them visible at all times

Bug Fixes

  • Inserting an image via drag and drop now places it at the correct location in the layer hierarchy
  • Fixes a bug where Sketch could crash when creating a Symbol from Shape Paths
  • Flattening bitmaps no longer flattens them to 2x resolution by default
  • Fixes a bug where shapes with subpaths wouldn’t recalculate their bounds when their boolean ops changed
  • Fixes a bug where the tab order in the color inspector was unexpected
  • Fixes a bug where flattening bitmaps on a retina screen might have them jump by a pixel
  • Layer Alignment has been improved to snap independently of axis
  • Fixes a bug where the Edit › Scale sheet would not recognise the most recent input
  • Fixes a bug where the line height field wouldn’t accept decimal numbers
  • Fixes a bug where a Star’s radius could go beyond 100%
  • The export preview is now properly centered in the inspector
  • Magic Wand now properly supports varying DPI images
  • Smart guides no longer pick up measures for locked layers
  • A Star’s radius now just increments by 1% instead of 10%
  • Fixes a bug where disabled borders on text layers would show the trash can in the wrong location
  • Fixes a bug where setting corner radius on individual points wouldn’t be restricted to integer values
  • Fixes a bug where drawing a closed path using the Pencil tool could have the path disappear
  • Fixes a bug where a layout grid’s values could be set to invalid values
  • Edit › Select All when layer interaction is disabled now selects all slices, also in subgroups
  • Fixes an Undo issue when setting Text Lists
  • Fixes confusing undo labels when editing text
  • Fixes a bug where images with blending and bitmap effects would not be rendered properly
  • Scissors tool now works correctly when multiple subpaths are involved
  • Fixes a bug where an outer path might leak a fill
  • Fixes a bug where duplicated Symbols would take the name from the group, instead of the previous Symbol
  • Smart Name suffixes are now also used for Duplicated Symbols and Styles
  • Fixes keyboard shortcuts on Dvorak, Colemak and non-Latin keyboards
  • Fixes a bug where the color preview box would not show a color with opacity when the real color had none
  • Fixes a bug where alt-dragging and then duplicating might not remember the offset
  • Improves snapping accuracy, especially for text layers
  • Fixes a bug where a color preview wouldn’t show the right opacity
  • Fixes a bug where dragging a rectangular area could leave artefacts
  • Fixes a bug where editing rotated images could leave artefacts

What's new in version 3.2

New Features

  • New Google Material Design template and artboard sizes.
  • Adds support for Sketch-Mirror and @3x scaling.
  • Align and Distribute tools now work for Vector points too.
  • You can now measure the distance from a shape to a grid or guide line using the Alt key as well.
  • Alt + click on the Inspector's align buttons to align the entire selection with their parent artboard.
  • Added a new preference to choose the resolution to which bitmaps are flattened when doing Layer › Flatten Selection to Bitmap.
  • When rotating objects, the pivot point can now be moved.
  • Shift+Return now inserts a line break instead of a paragraph break in text editing mode.

Enhancements

  • Significant speed improvements, especially when working with complex documents, Make Grid for large grids and undo & redo actions.
  • Improves PDF importing.
  • When changing text line height, the first line no longer clips off the top.
  • Renamed the Paste option in contextual menus to "Paste Here", to make the functionality clearer.
  • Improved compatibility with Yosemite.
  • Multiple corner radii for rectangles can now be provided from the inspector field using top/left/bottom/right syntax.
  • When duplicating layers or groups with slices in them, Sketch will now make sure their names are uniqued.
  • You can now perform math operations in the color (RGB/HSB) text fields.
  • Improves 'Copy CSS Attributes' for cleaner and more modernised output.
  • Inserting slices now always places them directly in the correct group, and they take the name of their parent group automatically.
  • Pixel grid can now also be shown and hidden in vector preview.
  • When vector points are hidden, the currently selected point handles are still being shown.
  • Smart guides in vector tool now also work as expected when the vector points are hidden.
  • When changing a subrange of a text with a shared style, the entire string now changes to reflect it.

Interface

  • Double-click on the zoom icon in the toolbar now zooms back to 100%.
  • Alt-clicking on the Move Forward/Backward toolbar buttons moves to front or back instead, and now also updates their labels to indicate this.
  • Auto-expanding of groups in the layer list is now optional. Also, Sketch now persists the expanded/collapsed states of groups in the layer list between restarts.
  • Artboard preset group now remember their collapsed state.
  • Scale fields now disable properly when exporting in vector formats.
  • The Release Notes can now be shown from the Help menu as requested.
  • You can now hide all Grids and Layouts in one click from the View menu.

Bug Fixes

  • Fixes a layer renaming bug in the layer list with multiple selections.
  • Fixes a bug where 'Make Grid' could make objects jump.
  • Fixes a number of refresh issues in vector editing mode.
  • Fixes a bug where changing blurred objects radius could seem to make it jump around weirdly.
  • Fixes a rare bug where documents with embedded pdf images could crash.
  • Fixes a bug where the Insert-Artboard inspector wouldn't work as expected when a layer was already selected.
  • Fixes a bug where one couldn't grab the handles of rotated shapes in groups.
  • Fixes a bug where background blur on rotated objects would misbehave.
  • Fixes a bug where deleting large numbers of layers would become really slow.
  • Fixes a bug where editing points in zoom-blurred layer wouldn't refresh the canvas properly.
  • Fixes a crasher that could occur when closing complex documents.
  • Fixes a bug where a text layer with a stroke and shadow might not display the right fill color.
  • Fixes a bug where font ascenders could get cropped under a text layer.
  • Fixes a bug where big shadows on text layer could get clipped.
  • Fixes a bug where nudging a shape inside a smaller artboard would move it out.
  • Fixes a bug where pasting text wouldn't strip the text style properly.
  • Fixes a bug where the system sharing sheet wouldn't export SVG files.
  • Fixes a bug where text layers wouldn't scale down properly.
  • Fixes an undo bug when pasting and reordering layers.
  • Fixes a bug where you could select layers inside locked groups.
  • Fixes a bug where the toolbar zoom icons wouldn't respond correctly.
  • Fixes an issue in using the screen color picker on multi-screen setups.
  • Fixes a refresh issue in using subpaths with thick strokes.
  • Fixes a refresh issue when moving artboards around with guides.
  • Fixes a Magic Wand bug on Retina screen.
  • Fixes a bug where slice names wouldn't get de-duplicated after copying.
  • Fixes a bug where pasted text background might stay around during edit and couldn't be removed.
  • Fixes a bug where layers dragged to new pages wouldn't get selected.
  • Fixes a bug where axis-constraining using shift when dragging layers wouldn't work.
  • Fixes a bug where selecting layers in the list could make the list jump around unexpectedly.
  • Fixes a bug where the color inspector would highlight the wrong color as being the current fill/border.
  • Fixes a bug where the Export button in the toolbar would add an incorrect slice to the document.
  • Fixes a bug where hiding a naming during renaming it would make its name invisible.
  • Fixes a bug where shadows wouldn't display correctly when being inside rotated or flipped groups.
  • Fixes a bug where text could unexpectedly be set to fixed width.
  • Fixes a bug where rotated shapes in groups would scale incorrectly.
  • Fixes a bug where measurement numbers for flipped layers would be flipped too.
  • Fixes a bug where text excluded from Symbol sync could act in an unpredictable way.

What's new in version 3.1

  • Sketch's file format has changed; documents are now truly single files and can be safely emailed or shared via Dropbox and other services without having to zip them up first
  • Creating Masks has been made easier; the Mask-with-Shape button now accepts any combination of layers
  • Boolean op'ed shapes' bounds now only include the visible area only, not the total bounds of all subpaths
  • Layer snapping has been made smarter, including better text snapping
  • You can now add ruler guides with a single-click on the rulers
  • Significant speed increases and file size reduction when using pattern fills
  • Hover the Rulers for a quick preview of your next guide. Ideal also for quickly checking if layers align etc
  • Fixes a bug where Opacity wouldn’t be rendered consistently between shapes and bitmaps
  • Rendering speed improvements
  • Fixes a bug where text editing could jump slightly when zoomed in some cases
  • Pages Panel has been redesigned and now fits as a permanent sidebar in the UI
  • You can drag/drop layers to the pages panel to quickly move objects between pages
  • Fixes a bug where Sketch could crash when a symbol name started with @
  • Fixes all known bugs in Framer - Sketch integration
  • Improves integration with the system color picker for gradients
  • Cmd+Return can now be used to exit text editing mode
  • You can now reset the rulers by double-clicking the ruler intersection area
  • Improves the zoom tool on dark backgrounds
  • Significant speed improvements when the rulers are visible
  • Improves undo for renaming layers
  • Fixes a bug where renaming Symbols could cause a crash
  • Fixes a bug where dragging out an SVG slice could crash Sketch
  • The Scissors Tool now scales properly with zoom value
  • Fixes a bug where patterns wouldn’t be drawn in the shared styles preview
  • Fixes a bug where Angular gradients could be rendered at low resolution
  • Fixes a bug where adding a guide could place it on subpixels
  • Fixes a bug where slices created for rotated objects could be one pixel off
  • Fixes a bug where point coordinates outside an artboard could be wrong
  • Due to popular request (no it wasn’t a bug), we’re making move Forward/Backward dumb again
  • You can now replace the contents of an image layer with a new image by going to Layer › Image › Replace
  • Restore an image to its original size by going to Layer › Image › Original Size
  • Fixes a bug where some documents could consume extraordinary amounts of CPU
  • Color and Gradient presets now display a checkered background when they’re transparent
  • Fixes a bug where creating a slice for a transparent layer could make the slice too big
  • Large patterns are now properly scaled to fit the small preset previews
  • Fixes a bug where deleting an artboard could leave its outline on the canvas in some cases
  • Fixes an issue where Gradient editing was confusing when started on a subpath
  • Fixes a bug where 'Bring to Front' on multiple layers could get their order mixed up
  • Fixes a bug where extra spaces wouldn’t get trimmed around slice names
  • Fixes a bug where moving layers off an artboard with the arrow keys would never actually remove them from the artboard
  • Fixes a bug where inserting an artboard while you were in a rotated group could look funky
  • Fixes a bug where pasted text could be invisible at first
  • While inserting a layer you can now drag outside the canvas to make the view scroll
  • When changing guides in the preferences, the canvas now updates live to reflect the change
  • Moves Grid color settings to the grid settings sheet to make it more discoverable
  • Inserting points in vector mode on an existing line now also honours rounding preference
  • Fixes a bug in bitmap cropping
  • The templates folder can now be an alias or symlink
  • Fixes a bug where layer naming would go wrong
  • Vector point coordinates in the inspector now round to two decimals
  • When you resize an artboard from the top or the left, the content stays anchored in the canvas now instead of shifting left or up
  • Symbols and Text Styles menu can now be arbitrarily deeply nested by using / in their names
  • Fixes a bug where text layers wouldn’t render multiple fills
  • Shift-clicking on a vector point now deselects it if it was already selected
  • View -> Collapse Groups has been renamed to include Artboards too
  • Fixes a bug where Magic Wand would miss the top 1 pixel
  • Flattening layers into a bitmap now inserts the bitmap at the location of the old layers instead of on top
  • Fixes Shared Styles break when copying and pasting style
  • Fixes a refresh issue when changing text layers from fixed to flexible width
  • Fixes a bug where Pencil vectors would not end up in the correct artboards
  • Ignore character spacing for the last character to not miss with centred text
  • Fixes a bug where making a grid of objects could rename the source object as well

What's new in version 3.0.4

  • Fixes a bug where items were pasted in the wrong position
  • Updated to latest CocoaScript
  • Adds experimental support for the shouldKeepAround property in plugins
  • Fixes a bug where changing the font might not update the font weight popup.
  • Fixes a bug where the Vector tool could draw on the wrong artboard
  • Fixes a bug where Layout Grids are reset to defaults on opening
  • Fixes a bug where editing a text layer could make its position jump
  • Fixes a bug where text could disappear when editing
  • Fixes a bug where zooming and panning could unexpectedly zoom you out to 1%
  • Fixes a bug where exportable Layers might export with incorrect width
  • Centring a Layout Grid inside an Artboard improved
  • Minor performance improvements when dragging objects in large documents
  • Performance improvements when duplicating multiple objects
  • Fixes a bug where the tooltip for opacity would cover RGBA numbers
  • Fixes a bug where adding and dragging a guide would add too many undo steps
  • Fixes a bug where resizing artboards would not update Width / Height fields in Inspector
  • Improves the scripting support by fixing some cases where scripts could crash unexpectedly
  • Fixes a crasher when adding new text layers
  • Fixes a bug where an empty style name could make the inspector's section disappear
  • The X and Y fields in the shape inspector now display their coordinates based on the parent artboard instead of the page
  • Tabbing in shape handler now does updates the inspector's point coordinates
  • Images can be perspective-transformed again
  • Fixes a bug where a hidden layer list would show a blank area on a new document
  • Fixes an undo bug when enabling grids
  • Renaming exportable layers now properly updates the inspector
  • Trackpad pinch-to-zoom once again zooms into the mouse location
  • Fixes a bug where you wouldn’t be able to drag out fills or shadows to remove them
  • Fixes a bug where rotated subpaths dragged out of groups could be scaled up and leave artefacts on the screen
  • Fixes a bug where Sketch could crash when layers got down to a certain size
  • Standard OS color picker can once again be used to pick colors
  • Arrange > Lock is now properly disable for artboards
  • Fixes a bug where 'Paste In Place' with no selection would paste in the wrong position
  • Screen color picker now looks better against dark backgrounds
  • You can now also press Alt only halfway the drag to initiate a duplicate
  • You can now temporarily hide the vector points in edit mode by holding the Option key
  • Fixes a bug where text layers could get infinitely wide when resizing them together with other layers

What's new in version 3.0.3

  • Fixes a bug where text could disappear or appear cut off during editing
  • Fixes a possible crash during exporting
  • Fixes a bug where the Inspector could shrink after opening color popover
  • Fixes a bug where pasting an image from another document could have it end up in the wrong artboard
  • Fixes a bug where Wacom tablets could cause problems with Text Editing
  • Fixes a bug where copying image files from the finder could pick their icon, instead of the contents of the file itself
  • Layout an Square Grid are now two separate overlays which can be enabled at the same time and can be on or off per artboard
  • Fixes a bug where pasted text could appear at semi-random locations on the canvas
  • Fixes a bug where snapping with the vector tool in an artboard would be inaccurate
  • Fixes a bug where editing shapes would not work when the grid was visible
  • Fixes the inaccurate description tag in SVG export
  • Fixes a bug where slices dragged from the export preview would be in the wrong format
  • When opening an existing document any existing empty documents will be closed in the process
  • Uppercase and Lowercase commands work on subranges of text now as well
  • Fixes a bug in The View › Show Slices and View › Show Layers menu item
  • Fixes a bug where text attribute might not sync to other text layers during text editing
  • Fixes a bug in crash reporting
  • Scripting: Redesigned scripting window with output logging for easier debugging
  • Scripting: Adds a command to run the last script again

What's new in version 3.0.2

  • Various performance improvements
  • Fixes crashes related to undo
  • Fixes crashes and redrawing issues related to text editing
  • Fixes a bug where duplicated artboards would have the wrong size
  • Updates Web Design template
  • Fixes a bug where selecting another layer in edit mode would select too many layers
  • Fixes a bug where right-click would no longer directly select a layer
  • Fixes a bug in exporting where using slashes could cause the exported file to not have an extension
  • Fixes a bug where multiple gradient fills would influence each other's opacity
  • Fixes a bug where editing text in the Star's radius field would not work
  • Fixes a bug where the scroll track would appears over colour presets
  • Fixes Image pasting into wrong artboard
  • Fixes a bug where the Missing Fonts dialog failed to show for new documents
  • Hidden layer/slice states are no longer remembered between documents
  • Fixes a bug where objects would snap to the grid but be 1px off still
  • Increases the 'strength' of Grid and Alignment guides snapping
  • Changes the scripting backend from JSTalk to CocoaScript
  • Locked layers now stay in place when aligning them
  • Dragging the slice preview out to the desktop now exports it in the proper format
  • Setting value of a text field within a symbol to none (even though its value is “excluded”) will no longer remove the text layer
  • Fixes a rare bug where typing could be incredibly slow for some people
  • Resizing shapes no longer fits their subpaths to pixel edges to prevent a common problem when resizing at really small sizes
  • Fixes a bug where flattening a group to Bitmap removes it from parent group
  • Objects now always snap to the grid when the grid is visible, instead of listening to the general 'smart guides' preference

What's new in version 3.0.1

  • Fixes missing artboard presets
  • Fixes missing quicklook previews
  • Fixes a bug where inserting shapes at high zoom levels displays the width wrongly
  • Fixes a bug where the canvas would be blank after dragging the window between retina and non-retina screens
  • Fixes a typo in the preferences

What's new in version 3.0

  • Symbols, for reusing elements in your design
  • Text Styles and Layer Styles, redesigned and unified for a better experience
  • Redesigned Inspector, giving you quicker access to everything
  • Automatic Slices, export layers directly, without needing to set up manual slices
  • Export multiple resolutions from a single slice, at any scale
  • Improved PDF, EPS and SVG importing and exporting
  • Significant speed improvements
  • Presentation Mode, go full screen and hide all controls, perfect for showing off designs
  • Improved Bitmap editing with Magic Wand, Crop, Invert and Vectorize tools
  • Adds multiple updated Noise patterns
  • Improves the speed of Radial gradients
  • Updated Toolbar icons
  • Updated application Icon
  • Immediate grid previews in the grid sheet
  • Faster access to fills, borders and more in the new popovers
  • Vectorize stroke improvements
  • You’re no longer limited to 4 fills
  • Speed improvements in using the grid tool
  • New grid feature: create grid from one selected object
  • Improves color accuracy of images and text layers
  • Grab and drag Artboards around by their name
  • Improved plugins support
  • Adds a contextual menu for seeing which layers are under the mouse
  • Rounding specific corners on shapes has been made easier
  • Improved gradient editing
  • Improved Transform tool
  • Adds the ability to quickly collapse all groups
  • Flatten selected layers into a bitmap
  • Adds the ability to hide the artboard shadow
  • You can now drag a layer from the layer list directly out of Sketch to quickly export it
  • Improved CSS attributes exporting
  • Faster font previews in the text inspector
  • Filter between Slices and Layers in the Layer Tree
  • Improved Artboard tool with new Presets and organisation
  • Now easier to Flip layers vertically and horizontally
  • Ability to add Noise as a separate Fill type
  • Text tool now supports bullet points
  • Refined Menu layout
  • Your document’s most popular colors automatically generated
  • Can specify background color for Artboards
  • Can apply a background color to slices
  • Adds a welcome document for instructing first-time users
  • Redesigned website and support section
  • Smarter naming of duplicated layers
  • Fixes a bug where duplicated layers could end up in seemingly random locations
  • Improves document saving by no longer storing quick look previews in the bundle
  • Easier to change between RGB and HSB values
  • We can now scrub the labels below text fields to quickly adjust their value
  • Adds iOS Icon and Interface design templates with all standard UI elements as symbols
  • Improves Undo coalescing
  • Improves printing support
  • Improved PDF-book exporting
  • Fixes a redrawing bug when moving text layer with small line heights around
  • Fixes a bug where rotation would go in the wrong directly
  • Fixes a bug where text could get mysteriously indented
  • Fixes a bug where hiding the inspector and layer list could hide content on the canvas
  • Fixes a bug where the inspector content would mysteriously disappear
  • Switching between open applications with the eyedropper tool
  • Fixes a bug in using nine-slice resizable bitmap images
  • Adds a Web design template with forms, buttons and more
  • Ability to organize Symbols, Layer and Text styles
  • Can edit and preview gradients in the Fill popover
  • Can now flip gradients in 90º increments
  • Adds Paste-in-place
  • Better layer search field
  • Instant access to font-selector (command+T)
  • Temporary zoom out to 100% when pressing §
  • Use Tab / Shift+Tab to switch between vector-edit points
  • Automatically lock ratio when shift+insert a shape
  • 1-9 to change opacity on fills and borders (when popover is open)
  • Alt+Tab to instantly focus on first field in inspector (for selection)
  • Improvements when pasting text from outside Sketch
  • Auto focus on shadow / inner-shadow fields when adding them
  • Smart guides now also measure distances from locked layers
  • Apply last-used offset when duplicating (if any)
  • Improvements and fixes in scripting
  • Click on artboard group to instantly create artboards for each size
  • Shortcut key for artboard and slice
  • Escape to clear search results
  • Gradient borders
  • Fixes and better accuracy for .eps importing
  • Option to fill up shapes with subpaths (non-zero, even-add)
  • Easily change font-size using font-size handler
  • Export based on pixel size or h e.g 1024w or 640h
  • Easily limit span of gradients

And we’ve probably forgotten a few as well...