Symbols

Symbols are a new feature in Sketch 3 and let you reuse groups of context easily across pages and artboards. They are local to your document though and cannot be shared between documents.

A symbol is in fact nothing more than a special kind of group. It is also displayed as a group the layer list, but with a purple instead of a blue icon.

Creating Symbols

To create your first symbol, select a group, or a number of layers and click the Create Symbol icon in the toolbar, or go to Layer › Create Symbol in the menu.

If whatever you had selected wasn’t yet a group, Sketch will group them together first. You now have a purple icon in the layer list and you can give your Symbol a new name in the inspector.

Now you can go to Insert › Symbol, and insert a new instance of your Symbol into the canvas. Likewise you can copy-paste or duplicate an existing instance of a symbol and Sketch will link them together as well.

Any edits you make in one instance are immediately reflected in the others.

Exclude Text

A common example of a Symbol will be something like a website header, or footer or common interface elements such as buttons. In all these cases you may want to make an exception for some of text in the symbols; each button should look the same, but its text value should probably be different.

You can easily do this with Symbols, by selecting a text layer inside a Symbol and checking the Exclude Text Value from Symbol checkbox. Any edits you make to the text are now local to only that instance.

Organising Symbols

If you create a lot of symbols in your document you may want to group them together somehow, because a long list of symbols isn’t that helpful.

If you go to Insert › Symbol › Manage Symbols, you will get a dropdown sheet with a list of all the symbols in your document. You can rename or delete them there. If you include a slash (/) in the name of the Symbol, Sketch will treat these as group separators. For example, two Symbols named Button/Normal and Button/Pressed will be grouped together into a submenu called Button.

Note that they are always sorted alphabetically, not in their order of creation.

Duplicating Symbols

If you want to duplicate an existing Symbol, select an instance of it in the canvas, and in the inspector click on the Symbol and choose “Duplicate Symbol”.

Swapping Symbols

In the same way, you can apply another Symbol to the currently selected instance. In the example of a pressed button and a normal button, you can swap between the two, leaving their text value the same if you’ve set up both Symbols to work that way:

To make this work, make sure that the text label is set to “Exclude Text Value from Symbol” in both symbols, and that it has the same name in the two (otherwise the value will be lost when swapping the Symbols).