Shortcuts

You can use keyboard shortcuts in Sketch to help speed up your design process.

To use a keyboard shortcut, press all the keys listed at the same time. Some commands are only enabled depending on what you are doing, or what you have selected, so we’ve split the commands into various sections.

General Shortcuts

C Copy
X Cut
V Paste
V Paste over selection
 Space -drag Pan Canvas
N New page
fn Previous page
fn Next page
+ Zoom in
- Zoom out
R Show/hide rulers
P Show/hide pixels
X Show/hide pixel grid
G Show/hide grid
L Show/hide layout
F Filter in Layer List
K Run custom plugin
Z Undo
Z Redo
N New document
O Open document
W Close window
S Save document
S Duplicate document
S Save document as…
P Page setup
, Open Preferences window
H Hide Sketch
Q Quit Sketch
? Open the Help menu

Inserting Layers

Select a shape type or tool, and click and drag in the Canvas to insert it.

R Rectangle
O Oval
L Line
U Rounded rectangle
V Vector tool
P Pencil tool
T Text tool
A Artboard tool
S Slice tool
-drag When inserting a layer, draw shape from center
-drag When inserting a layer, lock ratio of shape
 Space -drag Place newly drawn layer before confirming it

Selecting Layers

Click Select layer
Click-and-drag Select multiple layers
-drag Selects layer within drag bounds
Double-click layer Select grouped layer
-click layer Select any layer
-click layer Select an obscured layer
A Select all
A Select all Artboards
-click Add layer to selection/deselect layer in Canvas
-click Add layer from group to selection in Canvas
-click Add layer to selection/deselect layer in Layer List
-click Select a range of layers in Layer List
fn Select next Artboard
fn Select previous Artboard
J Reveal selection in Layer List

Moving and Resizing Layers

As you move or resize layers, smart guides and distance parameters are automatically visible.

-hover Display distance between other layers
D Duplicate
-drag Duplicate
-drag Move layer along X/Y axis
-drag Move layer ignoring smart guides
-drag Move an obscured layer
Arrow keys Nudge layer any direction by 1 px*
-Arrow keys Nudge layer any direction by 10 px*
K Scale layer
and resize Resize layer from center
and resize Preserve layer ratio
or Expand by 1 px
or Contract by 1 px
or Expand by 10 px
or Contract by 10 px
-hover Show distance to baseline/cap height on text layers

*This value can be changed in the application preferences.

Editing Layers

When you’ve a layer selected you can use the following shortcuts:

Enter Edit layer
Escape Finish editing
Delete layer
C Copy style
V Paste style
S Sync shared style
S Reset shared style
F Toggle fill
B Toggle border
C Pick color
0 to 9 Edit layer opacity
T Transform shape
R Rotate layer
M Use as mask
Escape Return to instance
U Union multiple layers
S Subtract multiple layers
I Intersect multiple layers
X Show Difference between multiple layers

Vector Editing

O Open/close path
Tab Selects next point
Show all handle control points
1 Straight point type
2 Mirrored point type
3 Disconnected point type
4 Asymmetric point type
Double-click vector point Toggle point between Straight and Mirrored
-drag vector point Move point along X/Y axis
-drag handle control point Converts selected point to Disconnected
-click (when inserting points) Place new point at a 45º angle
-click path segment Place new point between existing points

Text Editing

V Paste as rich text
T Change typeface
B Bold
I Italic
U Underline
+ Increase font size
- Decrease font size
L Increase character spacing
T Decrease character spacing
{ Align left
| Align center
} Align right
 Space  Emoji & symbols
O Convert to outlines
Return Insert a line break

Arranging Layers

These shortcuts and commands can be used to help you organize your document in the Layer List.

G Group
G Ungroup
R Rename layer
Tab Select next layer in group
Tab Select previous layer in group
Enter Selects layer inside group
Escape Selects parent group
Click-and-drag layer Adjust layer hierarchy
Bring forward
Bring to front
Send backward
Send to back
Move up (out of group/Artboard)
H Distribute horizontally
V Distribute vertically
-click Align buttons Align layer to Artboard
H Hide/show layer
L Lock/unlock layer

Exporting Layers

E Export
E Export selected layer(s)
Drag a layer/thumbnail to Desktop Export asset
Drag a layer/thumbnail to Canvas Insert flattened duplicate
/ in layer name Includes folder in export

Zoom and Focus

0 Zoom to 100%
1 Zoom to all elements on Canvas
2 Zoom to selected layer(s)
3 Center selected layer(s) in the Canvas
Z-drag Zoom to area
Z-click Zoom in
Z-click Zoom out
~ (§ on some keyboards) Temporarily zoom out to 100%
F Toggle full screen
1 Show/hide Layer List
2 Show/hide Inspector
. Enter presentation mode
T Show/hide Toolbar

Text Fields

Some handy shortcuts you can perform when you’re in a numerical field in the Inspector:

Tab Focus Inspector
Tab Select next field
Tab Select previous field
Enter Confirm change
Escape Clear change
Increase value by 1
Decrease value by 1
Increase value by 10
Decrease value by 10
Increase value by 0.1
Decrease value by 0.1

Size Fields

When adjusting the height or width of a layer, enter the following character after your value to resize from that position. Press the Enter key to confirm:

L Scale from the left (default)
R Scale from the right
T Scale from the top (default)
B Scale from the bottom
C / M Scale from the center / middle

Math Operators

You can perform math in all numerical inputs of the Inspector. Just apply an operator between two values and press the Enter key to confirm:

+ Add
- Subtract
* Multiply
/ Divide
% Resize layer to a percentage of its parent group or Artboard

Multiple Radiuses

With a rectangle selected, in the radius input field you can specify a different value for each corner.

; Value spacer. Eg, 40;0;40;0

Export Fields

In the Scale field, enter the following character after a number to get different results.

X Scale multiplier. Eg, 2x will export at twice the size
H Exports layer at the specified height. Eg, 512h
W Exports layer at the specified width. Eg, 512w

Miscellaneous

Here are the remainder of shortcuts available in Sketch that don’t fit into any of the above sections. These shortcuts are dependant on which tool you’re in, or what action you’re doing.

R Run last-used plugin again
-drag selection handle Rotate layer
-drag when rotating Snap rotation to 15º increments
0-9 With a gradient stop selected, position it between 0% and 100%
= Position selected gradient stop directly between two existing stops
Double-click Rulers intersection Reset Ruler co-ordinates

Custom Shortcuts

Custom shortcuts can be created via macOS System Preferences. To add your own custom shortcut, open the System Preferences and navigate to Keyboard › Shortcuts › App Shortcuts and click the add button. In the pop-up menu, select Sketch under Application. You will now be able to define your custom shortcut.